Track Layout editor: Design your own circuits 

Hint: quick start with track layout editor, click here

The circuit editor has a WYSIWYG interface allowing track section manipulation. Each circuit is edited in a MDI child window.

Track sections are added by clicking twice, or by dragging and dropping the selected track section from track section toolbar into the track layout editor window.

When a track section is dropped on the editor window, it is automatically attached to the closest track section if any.

 

UR30 circuit editor manages:

         circuit statistics: track length, number of right/left curves depending on the slot car direction

         several zoom factors

         a track library editor you can use to design your own tracks

         track section operations: gap suppressor, mirror track, flip, replacement, deletion, move...

         the most used track libraries such as Ninco, Carrera, Scalextric, Aurora, Artin...

         track adapters to manage several libraries together

         scenery objects

         3D render

         rooms

         grids and snaps

         track borders

         an html report generator to publish your track layouts on the web

         a track layer and an object layer

 

The toolbars contains short cut buttons to the most used track layout editor features.

The status bar on the main window bottom indicates the most editor useful information like the mouse location, current selected track section name and reference.

 

Access to the editor commands with menu bar items:

                      File menu

                      Edit menu

                      View menu

                      Circuit menu

                      Window menu

                      Help menu

 Track layout editor keyboard and mouse shortcuts:

 

<Arrow keys>

Scroll the editor view to the left, right, top or bottom

<maj> + <arrow keys>

Scroll faster the editor view to the left, right, top or bottom

Mouse wheel

Zoom in/out editor view either in 2D editor mode or 3D render mode

<tab>

Move track selection from current selected track to the next one

<maj> + <tab>

Move track selection from current selected track to the previous one

<page up>

Select the previous track in the track palette

<page down>

Select the next track in the track palette

<M>

3D render only: zoom out

<P>

3D render only: zoom in

<J>

3D render only: scroll left

<L>

3D render only: scroll right

<I>

3D render only: scroll up

<K>

3D render only: scroll down

<up>

3D render only: roll up

<down>

3D render only: roll down

 

Some cheat codes can be typed into the race editor views.